Skip navigation
Banner: Online Gambas documentation (in German)
"Don't let the noise of others' opinions drown out your own inner voice. And most important, have the courage to follow your heart and intuition."

Contract: Login Login

Another Critical error

Add topic

Post

Another Critical error

When in Bleeding Edge software repo clicking on Goto button for ShowCaseMetaPackager I get a Critical error
Clicking Goto button of ShowCase works just fine

Critical error – bailing out

This is an error that has been elevated to critical error status because it occurred during the primary error mechanism reporting system itself (possibly due to it occuring within the standard output framework). It may be masking a secondary error that occurred before this, but was never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.PHP WARNING [2] is_file() [<a href='http://www.php.net/manual/en/function.is-file.php'>function.is-file.php</a>]: open_basedir restriction in effect. File(/var/www/vhosts/gambasshowcase.org/httpdocs/themes/GambasShowCaseDark/templates_cached/EN/EMOTICON_IMG_CODE_THEMED.tpl.tcp) is not within the allowed path(s): (/var/www/vhosts/whiteislandsoftware.com/:/tmp/) in sources/tempcode.php(1668) : eval()'d code on line 2 (version: 9.0.5, PHP version: 5.3.3, URL: /index.php?page=catalogues&type=entry&id=bleeding-edge%2Fshowcasemetapackager)Details here are intended only for the website/system-administrator, not for regular website users.
» If you are a regular website user, please let the website staff deal with this problem.

Depending on the error, and only if the website installation finished, you may need to edit the installation options (the info.php file).
ocProducts maintains full documentation for all procedures and tools. These may be found on the ocPortal website. If you are unable to easily solve this problem, we may be contacted from our website and can help resolve it for you.

Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top

Post

Solved  :thumbs:

Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top

Post

When clikcing on the sofware entry for ShowCase in Bleeding Edge (ShowCaseMetaPackager as well!!)

Critical error – bailing out

This is an error that has been elevated to critical error status because it occurred during the primary error mechanism reporting system itself (possibly due to it occuring within the standard output framework). It may be masking a secondary error that occurred before this, but was never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.PHP WARNING [2] is_file() [<a href='http://www.php.net/manual/en/function.is-file.php'>function.is-file.php</a>]: open_basedir restriction in effect. File(/var/www/vhosts/gambasshowcase.org/httpdocs/themes/GambasShowCaseDark/templates_cached/EN/EMOTICON_IMG_CODE_THEMED.tpl.tcp) is not within the allowed path(s): (/var/www/vhosts/whiteislandsoftware.com/:/tmp/) in sources/tempcode.php(1668) : eval()'d code on line 2 (version: 9.0.5, PHP version: 5.3.3, URL: /index.php?page=catalogues&type=entry&id=bleeding-edge%2Fshowcase)Details here are intended only for the website/system-administrator, not for regular website users.
» If you are a regular website user, please let the website staff deal with this problem.

Depending on the error, and only if the website installation finished, you may need to edit the installation options (the info.php file).
ocProducts maintains full documentation for all procedures and tools. These may be found on the ocPortal website. If you are unable to easily solve this problem, we may be contacted from our website and can help resolve it for you.
ocPortal is a CMS for building websites, developed by ocProducts.


Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top

Post

Back to the top

Post

Now, when clicking on one of my project forums I get a critical error on all except Gambas ShowCase  O_o

EDIT:
Clikking OpenBox forum of Kona:

Critical error – bailing out
This is an error that has been elevated to critical error status because it occurred during the primary error mechanism reporting system itself (possibly due to it occuring within the standard output framework). It may be masking a secondary error that occurred before this, but was never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.
PHP WARNING [2] is_file() [<a href='PHP: is_file - Manual'>function.is-file.php</a>]: open_basedir restriction in effect. File(/var/www/vhosts/howtogambas.org/httpdocs/themes/HowTo_Tan/templates_cached/EN/COMCODE_IMG.tpl.tcp) is not within the allowed path(s): (/var/www/vhosts/whiteislandsoftware.com/:/tmp/) in sources/tempcode.php(1668) : eval()'d code on line 2 (version: 9.0.5, PHP version: 5.3.3, URL: /forum/index.php?page=forumview&id=openbox-cc)

Details here are intended only for the website/system-administrator, not for regular website users.
» If you are a regular website user, please let the website staff deal with this problem.

Depending on the error, and only if the website installation finished, you may need to edit the installation options (the info.php file).

ocProducts maintains full documentation for all procedures and tools. These may be found on the ocPortal website. If you are unable to easily solve this problem, we may be contacted from our website and can help resolve it for you.

ocPortal is a CMS for building websites, developed by ocProducts.

Last edit: by gbWilly


Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top

Post

Fixed.

I wish I could find the key to resolving this problem with the open_basedir setting on the server. The band-aid fix is just clearing the CMS cache.
Back to the top

Post

Here we go again with the Critical errors:
Software repo -> Bleeding Edge
-> LibGb3DevAidHelp
-> ShowCase

ALL other Bleeding Edge apps show up normal
Software repo -> New Stable releases
-> DebianPackageInstaller
-> LibGb3DevAid

All other new stable releases shop up normal

Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top

Post

Fixed.

Starting this weekend I should have much more free time again and I'll see if I can finally put an end to this irritating error.
Back to the top

Post

Critical error when clicking on:
Project Gambas3 Show Case
Project LibGb3DevAid
Gambas3 Code Snippets -> Add Arguments to application
 :(

Another note: Software repo hasn't got a version 3.4 to choose from and will need a 3.3 older version reference possibility.
Just so you know…. :thumbs:

Last edit: by gbWilly


Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top

Post

Cache cleared (for now).

When reporting these errors:
  • I need to know which site is causing the problem. This info can be copied from the critical error (see section in red).
  • Also tell me if you had accessed the same area from another site (and which one) prior to getting the critical error. Someone prior to you may have visited the same area and triggered the start of the error.

I'm gathering information as to how this is happening.

Critical error – bailing out
This is an error that has been elevated to critical error status because it occurred during the primary error mechanism reporting system itself (possibly due to it occuring within the standard output framework). It may be masking a secondary error that occurred before this, but was never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.
PHP WARNING [2] is_file() [<a href='PHP: is_file - Manual'>function.is-file.php</a>]: open_basedir restriction in effect. File(/var/www/vhosts/howtogambas.org/httpdocs/themes/HowTo_T
an/templates_cached/EN/COMCODE_IMG.tpl.tcp) is not within the allowed path(s):
(/var/www/vhosts/whiteislandsoftware.com/:/tmp/) in sources/tempcode.php(1668) : eval()'d code on line 2 (version: 9.0.5, PHP version: 5.3.3, URL: /forum/index.php?page=forumview&id=openbox-cc)
Back to the top

Post

Important!
Important!

Post

Important!

sholzy said

Starting this weekend I should have much more free time again and I'll see if I can finally put an end to this irritating error.

This may be fixed finally! I've done some minor testing and found no problems, but it needs more usage to know for sure.
Important!

Post

So far so good, everything seems to be working…
Will get back if things change..Thanks.. :thumbs:

Take care,

Willy


Systems:
Linux Mint 13 - Mate 1.6 - Gambas 3.4.2
Ubuntu 10.04 - Gnome 2.30 - Gambas 3.5.2
Raspbian wheezy - LXDE 0.5.10 - Gambas 3.5.2 (on a Raspberry Pi)
Lubuntu 12.04 - LXDE 0.5.8 - Gambas 3.5.2 (on a 11 year old PC!!)
 (+ a bunch of VMs with Debian, Fedora, Kubuntu, Lubuntu, Ubuntu, Linux Mint and Salentos for application testing purposes
 running either Gambas 3.4.1, Gambas 3.4.2, Gambas 3.5.1, Gambas 3.5.2, Gambas 3.5.3 or Gambas 3.5.90)

Projects:
Gambas ShowCase, a Gambas 3 applications software center.
How To Gambas, a series of guides to learn programming in Gambas 3.
GambOS, a distribution aimed at being a Gambas 3 learning environment.
Library Gambas3 Developer Aid, a Gambas 3 library to for retrieval of system info, bug reporting and more.

gbWilly said

What strikes me most is that, every time I don't really know how to do something in Gambas
in the end it turns out to be much more simple than I ever expected…
Back to the top
1 guest and 0 member have just viewed this.